Re: [PATCH 25/31] swim: Move swd initialization
Laurent Vivier <[email protected]> Sun, 26 Jul 2026 17:40:08 +0200
| Newsgroups | org.kernel.vger.linux-m68k,org.kernel.vger.linux-block,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
Le 16/07/2026 =C3=A0 12:02, Finn Thain a =C3=A9crit=C2=A0: > For better readability, initialize the swd backpointer along with the > other floppy_state struct members. No functional change. >=20 > Signed-off-by: Finn Thain <[email protected]> > --- > drivers/block/swim.c | 3 +-- > 1 file changed, 1 insertion(+), 2 deletions(-) Reviewed-by: Laurent Vivier <[email protected]> >=20 > diff --git a/drivers/block/swim.c b/drivers/block/swim.c > index 4679f554fec5..c41d56ab6c04 100644 > --- a/drivers/block/swim.c > +++ b/drivers/block/swim.c > @@ -760,6 +760,7 @@ static int swim_add_floppy(struct swim_priv *swd, en= um drive_location location) > struct floppy_state *fs =3D &swd->unit[swd->floppy_count]; > struct swim __iomem *base =3D swd->base; > =20 > + fs->swd =3D swd; > fs->location =3D location; > =20 > swim_motor(base, OFF); > @@ -855,8 +856,6 @@ static int swim_floppy_init(struct platform_device *= pdev) > err =3D PTR_ERR(swd->unit[drive].disk); > goto exit_put_disks; > } > - > - swd->unit[drive].swd =3D swd; > } > =20 > for (drive =3D 0; drive < swd->floppy_count; drive++) {