Re: [PATCH 29/31] swim: Define macros for constants
Laurent Vivier <[email protected]> Sun, 26 Jul 2026 17:46:11 +0200
| Newsgroups | org.kernel.vger.linux-m68k,org.kernel.vger.linux-block,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
Le 16/07/2026 =C3=A0 12:02, Finn Thain a =C3=A9crit=C2=A0: > Define a SEL_MASK macro to name the anonymous constant. Define STEPPING > rather than re-use STEP because the latter is a command bit macro (see a= lso > GCR_MODE vs. SETGCR). No functional change, just better readability. >=20 > Signed-off-by: Finn Thain <[email protected]> > --- > drivers/block/swim.c | 6 ++++-- > 1 file changed, 4 insertions(+), 2 deletions(-) Reviewed-by: Laurent Vivier <[email protected]> >=20 > diff --git a/drivers/block/swim.c b/drivers/block/swim.c > index 406792952e7f..460f74c19cfd 100644 > --- a/drivers/block/swim.c > +++ b/drivers/block/swim.c > @@ -112,9 +112,11 @@ struct iwm { > #define LSTRB 0x0F8 > =20 > #define CA_MASK 0x0F7 > +#define SEL_MASK 0x100 > =20 > /* Select values for swim_select and swim_readbit */ > =20 > +#define STEPPING 0x0F1 > #define READ_DATA_0 0x0F4 > #define ONEMEG_DRIVE 0x0F5 > #define SINGLE_SIDED 0x0F6 > @@ -271,7 +273,7 @@ static inline void swim_select(struct swim __iomem *= base, int sel) > { > swim_write(base, phase, RELAX); > =20 > - via1_set_head(sel & 0x100); > + via1_set_head(sel & SEL_MASK); > =20 > swim_write(base, phase, sel & CA_MASK); > } > @@ -369,7 +371,7 @@ static int swim_step(struct swim __iomem *base) > { > swim_action(base, STEP); > udelay(150); > - return swim_readbit_timeout_atomic(base, STEP, false, 20 * 1000); > + return swim_readbit_timeout_atomic(base, STEPPING, false, 20 * 1000); > } > =20 > static int swim_track00(struct swim __iomem *base)