Re: [PATCH 1/2] dmaengine: use dma_chan_name() helper to get per-channel device name

Logan Gunthorpe <[email protected]>
Newsgroups org.kernel.vger.linux-mips,dev.linux.lists.imx,dev.linux.lists.linux-sunxi,org.infradead.lists.linux-arm-kernel,org.kernel.vger.dmaengine,org.kernel.vger.linux-kernel,org.kernel.vger.linux-tegra,org.kernel.vger.linux-trace-kernel
Message-ID <[email protected]>

On 2026-08-12 3:24 p.m., [email protected] wrote:
> From: Frank Li <[email protected]>
> 
> Use the existing dma_chan_name() helper to obtain the per-channel device
> name instead of open-coding: dev_name(chan->dev->device) /
> dev_name(chan2dev())
> 
> Simplify the code and improve consistency.
> 
> No functional change intended.
> 
> Signed-off-by: Frank Li <[email protected]>

Makes sense to me.

Reviewed-by: Logan Gunthorpe <[email protected]>
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.