Re: [PATCH 1/2] dt-bindings: mmc: Add post-power-off-delay-ms property

Judith Mendez <[email protected]> Wed, 22 Jul 2026 14:51:07 -0500
Newsgroups org.kernel.vger.linux-mmc,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
Hi Ulf,

On 7/18/26 8:15 AM, Ulf Hansson wrote:
> On Fri, Jul 17, 2026 at 7:40 PM Judith Mendez <[email protected]> wrote:
>>
>> Hi Ulf,
>>
>> On 7/17/26 5:21 AM, Ulf Hansson wrote:
>>> On Fri, Jul 17, 2026 at 1:26 AM Judith Mendez <[email protected]> wrote:
>>>>
>>>> Add post-power-off-delay-ms property to MMC controller common.
>>>>
>>>> This property shall be used to specify delay if needed after
>>>> deasserting power during MMC power cycles.
>>>
>>> Please clarify with some additional information from the cover-letter,
>>> like "specify custom delays after MMC power off to work around
>>> hardware issues such as slow RC circuites on MMC VDD rails."
>>>
>>>>
>>>> Signed-off-by: Judith Mendez <[email protected]>
>>>> ---
>>>>    .../devicetree/bindings/mmc/mmc-controller-common.yaml    | 8 ++++++++
>>>>    1 file changed, 8 insertions(+)
>>>>
>>>> diff --git a/Documentation/devicetree/bindings/mmc/mmc-controller-common.yaml b/Documentation/devicetree/bindings/mmc/mmc-controller-common.yaml
>>>> index 3d7195e9461c3..3ff68d32a308f 100644
>>>> --- a/Documentation/devicetree/bindings/mmc/mmc-controller-common.yaml
>>>> +++ b/Documentation/devicetree/bindings/mmc/mmc-controller-common.yaml
>>>> @@ -275,6 +275,14 @@ properties:
>>>>          not available.
>>>>        default: 10
>>>>
>>>> +  post-power-off-delay-ms:
>>>
>>> For mmc-pwrseq-simple we already have "power-off-delay-us", perhaps
>>> better to re-use that name instead.
>>
>> Besides having the same dt property name as mmc-pwrseq-simple what is
>> the benefit of switching to power-off-delay-us?
> 
> Using ms as the unit is limiting and completely unnecessary. What is
> some HW is fine with 300 us, for example.

Ok then, will use power-off-delay-us. thanks.

> 
>>
>> All values will have to be in us instead of ms and thus will look a bit
>> less clean in code. If it is just a naming  preference, I do prefer
>> the current name in this version, please let me know if we can keep:
>> post-power-off-delay-ms.
> 
> The code is a separate thing, this is the DT property for supporting
> different HWs.

got it, will fix and respin. thanks.

~ Judith