Re: [PATCH v8 08/10] rust: binder: use `LocalModule` for `THIS_MODULE`
Alice Ryhl <[email protected]> Mon, 13 Jul 2026 08:13:56 +0000
| Newsgroups | org.kernel.vger.linux-modules,dev.linux.lists.driver-core,dev.linux.lists.nova-gpu,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-block,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.linux-pci,org.kernel.vger.netdev,org.kernel.vger.rust-for-linux |
|---|---|
| Message-ID | <[email protected]> |
On Mon, Jul 13, 2026 at 02:45:29PM +0800, Alvin Sun wrote: > Replace the `THIS_MODULE` static reference in the binder fops with > `this_module::<LocalModule>()`, consistent with the move of > `THIS_MODULE` into the `ModuleMetadata` trait. > > Assisted-by: opencode:glm-5.2 > Reviewed-by: Gary Guo <[email protected]> > Acked-by: Danilo Krummrich <[email protected]> > Signed-off-by: Alvin Sun <[email protected]> Most other Rust Binder commits use 'rust_binder:' prefix rather than 'rust: binder:'. Alice