Re: [PATCH v8 07/10] rust: configfs: use `LocalModule` for `THIS_MODULE`

"Gary Guo" <[email protected]> Mon, 13 Jul 2026 13:07:24 +0100
Newsgroups org.kernel.vger.linux-modules,dev.linux.lists.driver-core,dev.linux.lists.nova-gpu,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-block,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.linux-pci,org.kernel.vger.netdev,org.kernel.vger.rust-for-linux
Message-ID <[email protected]>
On Mon Jul 13, 2026 at 7:45 AM BST, Alvin Sun wrote:
> Replace the `THIS_MODULE` static reference in the `configfs_attrs!`
> macro with `this_module::<LocalModule>()`, and update
> rnull to import `LocalModule` instead of `THIS_MODULE`, consistent
> with the move of `THIS_MODULE` into the `ModuleMetadata` trait.
> 
> Assisted-by: opencode:glm-5.2
> Reviewed-by: Andreas Hindborg <[email protected]>
> Acked-by: Danilo Krummrich <[email protected]>
> Signed-off-by: Alvin Sun <[email protected]>

Reviewed-by: Gary Guo <[email protected]>

> ---
>  drivers/block/rnull/configfs.rs | 5 +----
>  rust/kernel/configfs.rs         | 9 ++++++---
>  2 files changed, 7 insertions(+), 7 deletions(-)