Re: [PATCH v9 2/2] module: Rename module_blacklist to module_denylist

[email protected]
Newsgroups org.kernel.vger.linux-modules
Message-ID <[email protected]>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] The comment preceding the module_is_denylisted() call was not updated to reflect the new terminology.
--

--- Patch [2]: [PATCH v9 2/2] module: Rename module_blacklist to module_denylist ---
commit ac79bb8334a6a0d6e2353ff853444d535ab50178
Author: Aaron Tomlin <[email protected]>

module: Rename module_blacklist to module_denylist

This commit renames the kernel parameter and internal symbols from "blacklist"
to "denylist" while keeping the old parameter as a deprecated alias. Log
messages and documentation are also updated to reflect the new terminology.

[ ... ]

> diff --git a/kernel/module/main.c b/kernel/module/main.c
> index a9fd6aaedc69c..1a58313649d94 100644
> --- a/kernel/module/main.c
> +++ b/kernel/module/main.c
> @@ -3381,8 +3381,8 @@ static int early_mod_check(struct load_info *info, int flags)
>  	 * Now that we know we have the correct module name, check
>  	 * if it's blacklisted.

[Severity: Low]
This isn't a bug, but should this comment also be updated to say "denylisted"
to match the rest of the terminology changes in this patch?

>  	 */
> -	if (module_is_blacklisted(info->name)) {
> -		pr_err("Module %s is blacklisted\n", info->name);
> +	if (module_is_denylisted(info->name)) {
> +		pr_err("Module %s is denylisted\n", info->name);
>  		return -EPERM;
>  	}

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/[email protected]?part=2
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.