Re: [PATCH 3/6] Mempolicy: rename policy_types and cleanup initialization

Lee Schermerhorn <[email protected]>
Newsgroups org.kernel.vger.linux-numa,org.kvack.linux-mm
Message-ID <[email protected]>
On Mon, 2010-03-22 at 09:43 -0500, Christoph Lameter wrote:
> On Fri, 19 Mar 2010, Lee Schermerhorn wrote:
> 
> > Rename 'policy_types[]' to 'policy_modes[]' to better match the
> > array contents.
> 
> Reviewed-by: Christoph Lameter <[email protected]>
> 
> Small nitpick: MPOL_MAX should be called MPOL_NR to follow vmstat.h and
> mmzones.h's way of naming the n+1st element.

The 'MPOL_MAX' has been there since David R [wasn't it?] created the
enum.  The current name shows up in user space numaif.h from the numactl
package [2.0.3] as a #define of MPOL_MAX to MPOL_INTERLEAVE .  I suppose
we could #define it to MPOL_NR to avoid the possibility of application
breakage if the enum ever makes it to the user space header.   I checked
numactl sources and the only use of MPOL_MAX in the package is one of
the test programs.  Don't know about end user apps out there in the
wild, tho'.

David:  what do you think?

Lee

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to [email protected].  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"[email protected]"> [email protected] </a>
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.