Re: [PATCH 0/3] PCI/sysfs: Follow-up to the static attribute conversion

Krzysztof WilczyƄski <[email protected]> Sat, 1 Aug 2026 13:09:56 +0900
Newsgroups org.kernel.vger.linux-pci
Message-ID <20260801040935.GH3183355@rocinante>
Hello,

> This series is a follow-up to the PCI sysfs static attribute
> conversion [1], carrying the clean-up changes from its v8 revision.
> 
> The v7 revision of the series was applied and went out with the PCI
> pull request for 7.2 [2], so the changes from v8 did not land in time
> to make the 7.2 release.
> 
> The series consists of three clean-ups:
> 
>   - Add the pci_ prefix to the generated PCI resource attribute names
>     dev_resourceN_{io,uc,wc}_attr, for consistency with the macros
>     that generate them and the arrays that collect them.
> 
>   - Make the attribute name suffix the first parameter of Alpha's
>     __pci_dev_resource_attr() macro, resolving a checkpatch.pl
>     complaint about two consecutive commas.
> 
>   - Add the pci_legacy_resource_{io,mem}_attr() macros, and use them
>     for the legacy I/O and memory attribute definitions instead of
>     open-coding each struct bin_attribute.
> 
> These correspond to the items listed under "Changes in v8" in the v8
> cover letter [1].
> 
> No functional changes intended.
> 
> 1. https://lore.kernel.org/linux-pci/[email protected]/
> 2. https://lore.kernel.org/linux-pci/20260624110021.GA996382@bhelgaas/

Applied to the sysfs branch.

Thank you!

	Krzysztof