Re: [PATCH v19 05/14] cxl: Rename find_cxl_port() to find_cxl_port_by_dport()
[email protected] Mon, 03 Aug 2026 22:29:21 +0000
| Newsgroups | org.kernel.vger.linux-pci,org.kernel.vger.linux-cxl |
|---|---|
| Message-ID | <[email protected]> |
> From: Dan Williams <[email protected]> >=20 > find_cxl_port() and find_cxl_port_by_uport() are internal port lookup > functions that search the CXL bus by dport and uport respectively, but > their names do not make the lookup method clear. >=20 > Rename find_cxl_port() to find_cxl_port_by_dport() to make the lookup > method explicit and consistent with find_cxl_port_by_uport(). Both > functions remain static to port.c; the upcoming patch that adds the > first cross-file caller will widen their scope. >=20 > Make the same naming change to static helper __find_cxl_port_by_dport(). >=20 > Co-developed-by: Terry Bowman <[email protected]> > Signed-off-by: Terry Bowman <[email protected]> > Signed-off-by: Dan Williams <[email protected]> Sashiko has reviewed this patch and found no issues. It looks great! --=20 Sashiko AI review =C2=B7 https://sashiko.dev/#/patchset/20260803221810.3685= [email protected]?part=3D5