Re: [PATCH 2/2] misc: tc9564: introduce base PCI driver

"Arnd Bergmann" <[email protected]>
Newsgroups org.kernel.vger.linux-pci,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On Fri, Aug 14, 2026, at 03:11, Greg KH wrote:
> On Thu, Aug 13, 2026 at 05:29:42PM -0500, Alex Elder wrote:
>> +#define DRIVER_NAME "tc9564-pci"
>
> What about just using KBUILD_MODNAME?
>
>> +static int
>> +tc9564_function_probe(struct pci_dev *pdev, const struct pci_device_id *id)
>
> But wow, this is a tiny driver, feels odd to have it in misc/ but ok, if
> you think it should be here...

We have drivers/misc/rp1/ and drivers/misc/lan966x_pci*.c with similar
functionality, so at least there is precedence for putting them here.

From the old days, we still have drivers/mfd/sm501.c, drivers/mfd/cs5535-mfd.c,
and a few others that open-code the on-chip components as mfd cels
instead of using devicetree description.

At some point, we should think about grouping them into a separate
subdirectory.

     Arnd
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.