Re: [PATCH net-next V2 12/13] selftests: drv-net: psp: Fix responder parsing

Jakub Kicinski <[email protected]>
Newsgroups org.kernel.vger.linux-rdma,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.netdev
Message-ID <[email protected]>
On Tue, 11 Aug 2026 12:41:14 +0000 Cosmin Ratiu wrote:
> > > I actually replaced n by off. Did you mean "don't replace n by
> > > off"?  
> > 
> > Of course!
> >   
> > > Because the two are identical after the recv error checking. I
> > > don't
> > > see the point of maintaining two variables when one suffices.
> > > Either n
> > > or off can describe the number of bytes in buf. off is static and
> > > persists across chunks, while n is temporary.  
> > 
> > The variables have semantic meaning, which makes it easier to follow
> > the code.
> >   
> > > So to clarify, do you want to keep both?  
> > 
> > Yes.  
> 
> I'm sorry, but the code is wrong.
> cmd() matches on n (which never changes!) but __consume() only
> decrements off. Strap a loop on top and the result is just confusion
> and a source of bugs (e.g. the one I'm trying to fix with this patch).
> 
> A single variable should be used to keep track of the length of data
> left to parse.

and in your opinion that variable, which represents the amount of data
left to parse is supposed to be called "off" ?
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.