Re: [PATCH 3/6] clk: renesas: rzg2l: Add support for divider flags
Geert Uytterhoeven <[email protected]>
| Newsgroups | org.kernel.vger.linux-renesas-soc,org.kernel.vger.linux-clk,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <CAMuHMdU9EtPKbhLB3rmH5SCpwxkuEM+1eFRHmUi+UBzDWQAPdA@mail.gmail.com> |
Hi Biju, On Fri, 19 Jun 2026 at 18:40, Biju <[email protected]> wrote: > From: Biju Das <[email protected]> > > Add support for passing divider flags apart from clock flags from soc > specific clock drivers. > > Signed-off-by: Biju Das <[email protected]> Thanks for your patch! Reviewed-by: Geert Uytterhoeven <[email protected]> One nit below... > --- a/drivers/clk/renesas/rzg2l-cpg.c > +++ b/drivers/clk/renesas/rzg2l-cpg.c > --- a/drivers/clk/renesas/rzg2l-cpg.h > +++ b/drivers/clk/renesas/rzg2l-cpg.h > @@ -112,6 +112,7 @@ struct cpg_core_clk { > notifier_fn_t notifier; > u32 flag; I think the time is ripe to rename this to core_flags. Or at least add the plural "s" ;-) > u32 mux_flags; > + u32 div_flags; > int num_parents; > }; > Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email protected] In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds