Re: [PATCH] ASoC: generic: Card name parsing should be called after xxx_for_each_link()

Geert Uytterhoeven <[email protected]>
Newsgroups org.kernel.vger.linux-renesas-soc,org.kernel.vger.linux-sound
Message-ID <CAMuHMdXfwYbMhzU4Q4L3Gz1vaatJs8gdgPytVGRUCzWAHTVK1w@mail.gmail.com>
Hi Morimoto-san,

On Wed, 15 Jul 2026 at 04:13, Kuninori Morimoto
<[email protected]> wrote:
> "tidyup simple_util_parse_xxx() in xxx_parse_of()" commit changed the
> function call order. But simple_util_parse_card_name() should be called
> after dai_link settings, because it might use dai_link->name as card->name.
>
> Fixes: fa6222d5e121 ("ASoC: audio-graph-card2: tidyup simple_util_parse_xxx() in audio_graph2_parse_of()")
> Fixes: b8081307f5c9 ("ASoC: audio-graph-card: tidyup simple_util_parse_xxx() in audio_graph_parse_of()")
> Fixes: 27ecf4da5ad3 ("ASoC: simple-card: tidyup simple_util_parse_xxx() in simple_parse_of()")
> Reported-by: Mark Brown <[email protected]>
> Link: https://lore.kernel.org/r/[email protected]
> Reported-by: Geert Uytterhoeven <[email protected]>
> Link: https://lore.kernel.org/r/[email protected]

s/Link/Closes/

> Signed-off-by: Kuninori Morimoto <[email protected]>

Thanks, this revives (at least in dmesg) the sound cards on Koelsch
and RZ/Five (simple-audio-card).  Sound cards are still instantiated on
Salvator-XS (audio-graph-card) and Gray Hawk Single (audio-graph-card2).

Tested-by: Geert Uytterhoeven <[email protected]>

Gr{oetje,eeting}s,

                        Geert

-- 
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email protected]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.