Re: [PATCH] ASoC: generic: Card name parsing should be called after xxx_for_each_link()

Kuninori Morimoto <[email protected]>
Newsgroups org.kernel.vger.linux-renesas-soc,org.kernel.vger.linux-sound
Message-ID <[email protected]>
Hi Geert, Mark

Thank you for the feedback

> > Fixes: fa6222d5e121 ("ASoC: audio-graph-card2: tidyup simple_util_parse_xxx() in audio_graph2_parse_of()")
> > Fixes: b8081307f5c9 ("ASoC: audio-graph-card: tidyup simple_util_parse_xxx() in audio_graph_parse_of()")
> > Fixes: 27ecf4da5ad3 ("ASoC: simple-card: tidyup simple_util_parse_xxx() in simple_parse_of()")
> > Reported-by: Mark Brown <[email protected]>
> > Link: https://lore.kernel.org/r/[email protected]
> > Reported-by: Geert Uytterhoeven <[email protected]>
> > Link: https://lore.kernel.org/r/[email protected]
> 
> s/Link/Closes/

OK, will fix

> > Signed-off-by: Kuninori Morimoto <[email protected]>
> 
> Thanks, this revives (at least in dmesg) the sound cards on Koelsch
> and RZ/Five (simple-audio-card).  Sound cards are still instantiated on
> Salvator-XS (audio-graph-card) and Gray Hawk Single (audio-graph-card2).

Nice to know.

I noticed that I want to +1 update to this patch.
Basically no functional change, but is for cosmetic fix.
Will post v2 patch today.

Thank you for your help !!

Best regards
---
Kuninori Morimoto
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.