RE: [PATCH 3/6] clk: renesas: rzg2l: Add support for divider flags
Biju Das <[email protected]> Mon, 27 Jul 2026 19:06:52 +0000
| Newsgroups | org.kernel.vger.linux-renesas-soc,org.kernel.vger.linux-clk,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <TY3PR01MB11346DCB050BF2F5A72A5409D86CC2@TY3PR01MB11346.jpnprd01.prod.outlook.com> |
Hi Geert, Thanks for the feedback. > -----Original Message----- > From: Geert Uytterhoeven <[email protected]> > Sent: 10 July 2026 16:41 > Subject: Re: [PATCH 3/6] clk: renesas: rzg2l: Add support for divider flags > > Hi Biju, > > On Fri, 19 Jun 2026 at 18:40, Biju <[email protected]> wrote: > > From: Biju Das <[email protected]> > > > > Add support for passing divider flags apart from clock flags from soc > > specific clock drivers. > > > > Signed-off-by: Biju Das <[email protected]> > > Thanks for your patch! > > Reviewed-by: Geert Uytterhoeven <[email protected]> One nit below... > > > --- a/drivers/clk/renesas/rzg2l-cpg.c > > +++ b/drivers/clk/renesas/rzg2l-cpg.c > > > --- a/drivers/clk/renesas/rzg2l-cpg.h > > +++ b/drivers/clk/renesas/rzg2l-cpg.h > > @@ -112,6 +112,7 @@ struct cpg_core_clk { > > notifier_fn_t notifier; > > u32 flag; > > I think the time is ripe to rename this to core_flags. Or at least add the plural "s" ;-) Agreed. Will rename this to core_flags. Cheers, Biju