[ANNOUNCE] rt-tests-2.10

John Kacur <[email protected]>
Newsgroups org.kernel.vger.linux-rt-users
Message-ID <[email protected]>
We are pleased to announce rt-tests-2.10

To fetch: 

Clone one of the following
git://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git
https://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git
https://kernel.googlesource.com/pub/scm/utils/rt-tests/rt-tests.git

Branch: main
Tag: v2.10

Tarballs are available here:
https://kernel.org/pub/linux/utils/rt-tests

Older version tarballs are available here:
https://kernel.org/pub/linux/utils/rt-tests/older

Thank to everyone who contributed.
patches and bug-reports are always welcome.

John Kacur

Cheng-Yang Chou (8):
  rt-utils.c: Check return values of write()
  pmqtest.c: Check return values of write() and ftruncate()
  ptsematest.c: Check return values of write() and ftruncate()
  rt-migrate-test.c: Check return values of write() and ftruncate()
  cyclicdeadline.c: Check return values of write() and ftruncate()
  deadline_test.c: Check return values of write() and ftruncate()
  sigwaittest.c: Check return values of write() and ftruncate()
  svsematest.c: Check return values of write() and ftruncate()

Costa Shulyupin (2):
  rt-tests: hwlatdetect: Add field count to samples output
  hwlatdetect: Add MTBF calculation

Derek Barbosa (1):
  ssdd: mitigate tracee starvation

Gabriele Monaco (1):
  rt-utils.c: Fix write() return value check

John Kacur (5):
  hwlatdetect: Make count field backward compatible
  hwlatdetect: Add bounds checking and improve code readability
  rt-tests: cyclictest: Remove duplicate option in getopt string
  rt-tests: hwlatdetect: Add check that width is not zero
  rt-tests: Makefile: Bump version to v2.10

Luis Claudio R. Goncalves (1):
  hwlatdetect: correctly get CPU number from different sample formats

Sebastian Andrzej Siewior (10):
  README: Drop "debug" from the tracing path
  rt-utils: Remove mount_debugfs()
  rt-utils: Rename get_debugfileprefix() and let it look for tracefs
  queuelat, rt-migrate-test: Use tracefs for tracing
  rt-utils: Remove fileprefix.
  rt-utils: Simplify trace_file_exists()
  rt-utils: Decouple writing trace-marks with trace stopping
  sched_deadline: Use tracemark() from rt-utils instead custom
    implementation
  sched_deadline: Check the resulting size returned from snprintf()
  cyclicdeadline: Don't test for /sys/kernel/debug/sched_features

Tomas Glozar (1):
  rt-tests: cyclictest: Fix -A long name in manpage

 Makefile                              |   2 +-
 README.markdown                       |  13 ++-
 src/backfire/sendme.c                 |   2 +-
 src/cyclictest/cyclictest.8           |   4 +-
 src/cyclictest/cyclictest.c           |   3 +-
 src/hwlatdetect/hwlatdetect.py        |  46 +++++++-
 src/include/rt-utils.h                |   4 +-
 src/lib/rt-utils.c                    | 116 +++++++------------
 src/oslat/oslat.c                     |   1 +
 src/pmqtest/pmqtest.c                 |   8 +-
 src/ptsematest/ptsematest.c           |   8 +-
 src/queuelat/queuelat.c               |   2 +-
 src/rt-migrate-test/rt-migrate-test.c |   9 +-
 src/sched_deadline/cyclicdeadline.c   | 155 ++++++--------------------
 src/sched_deadline/deadline_test.c    |  37 +++++-
 src/sigwaittest/sigwaittest.c         |  15 ++-
 src/ssdd/ssdd.c                       |  65 ++++++++---
 src/svsematest/svsematest.c           |  15 ++-
 18 files changed, 257 insertions(+), 248 deletions(-)
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.