Re: [PATCH v4 13/15] rtc: rzn1: Add OF match data to gate SUBU register access
"Lad, Prabhakar" <[email protected]>
| Newsgroups | org.kernel.vger.linux-rtc,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel,org.kernel.vger.linux-renesas-soc |
|---|---|
| Message-ID | <CA+V-a8vwNHm+KZs74ktpuvxKjOcqLtcxGRFi8i-_g9jcPs_3yQ@mail.gmail.com> |
Hi Wolfram, Thank you for the review. On Wed, Aug 19, 2026 at 2:12 PM Wolfram Sang <[email protected]> wrote: > > > > + if (!scmp_val && !data->has_subu) > > + return -EOPNOTSUPP; > > I'd think here a helpful comment for the user is justified. Maybe "No > valid XTAL provided and SUBU mode not supported"? > Ok I will add a dev_err_probe(). > > +static const struct rzn1_rtc_data rzn1_data = { > > + .has_subu = true, > > +}; > > 'rzn1_data' is maybe too generic? rzn1_rtc_rzn1_data? Yeah, looks a bit > weird but I personally still like it better. > Ok I will rename this to rzn1_rtc_rzn1_data. Cheers, Prabhakar