[PATCH v2] s390/ap: Drop unused member from ap_device_id
Uwe Kleine-König (The Capable Hub) <[email protected]>
| Newsgroups | org.kernel.vger.linux-s390,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <55aa5d3b5b1794b5fca7f3ae75b48dcefa09e808.1786033091.git.ukleinek@kernel.org> |
ap_device_id::driver_info is not used in the kernel. The structure is also not part of API/ABI, so the unused member can just be dropped. Signed-off-by: Uwe Kleine-König (The Capable Hub) <[email protected]> --- Hello, Sashiko was quick to identify two issues in my patch. Before someone gets around to review v1 by hand, here is a v2 addressing Sashiko's concerns: - remove the typedef for kernel_ulong_t - s/device_info/driver_info/ in the commit log Thanks Uwe include/linux/device-id/ap.h | 2 -- 1 file changed, 2 deletions(-) diff --git a/include/linux/device-id/ap.h b/include/linux/device-id/ap.h index 0992333a34db..e050abebbf3d 100644 --- a/include/linux/device-id/ap.h +++ b/include/linux/device-id/ap.h @@ -4,7 +4,6 @@ #ifdef __KERNEL__ #include <linux/types.h> -typedef unsigned long kernel_ulong_t; #endif #define AP_DEVICE_ID_MATCH_CARD_TYPE 0x01 @@ -14,7 +13,6 @@ typedef unsigned long kernel_ulong_t; struct ap_device_id { __u16 match_flags; /* which fields to match against */ __u8 dev_type; /* device type */ - kernel_ulong_t driver_info; }; #endif /* ifndef LINUX_DEVICE_ID_AP_H */ base-commit: 1701fda2f58e345c050f4309971bdc07cd6146ba -- 2.55.0.11.g153666a7d9bb