Re: [PATCH v5 7/9] s390/vfio-ap: Fix hot-unplug skipped when last AP adapter or domain removed
Halil Pasic <[email protected]>
| Newsgroups | org.kernel.vger.linux-s390,org.kernel.vger.kvm,org.kernel.vger.linux-kernel,org.kernel.vger.stable |
|---|---|
| Organization | IBM |
| Message-ID | <[email protected]> |
On Wed, 12 Aug 2026 16:02:38 -0400 Anthony Krowiak <[email protected]> wrote: > @@ -2568,24 +2568,28 @@ static void vfio_ap_mdev_hot_unplug_cfg(struct ap_matrix_mdev *matrix_mdev, > unsigned long *aqrem, > unsigned long *cdrem) > { > - int do_hotplug = 0; > + bool do_hotplug = false; > Nit: The name is IMHO somewhat misleading. If we are already touching all uses of the variable and its type maybe we can use the opportunity to change it's name as well. Some ideas: update_apcb, changed, matrix_changed. [..] > > if (do_hotplug) > vfio_ap_mdev_update_guest_apcb(matrix_mdev); > --