Re: [PATCH v2] s390/ap: Drop unused member from ap_device_id
Vasily Gorbik <[email protected]>
| Newsgroups | org.kernel.vger.linux-s390,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On Thu, Aug 06, 2026 at 06:21:19PM +0200, Uwe Kleine-König (The Capable Hub) wrote: > ap_device_id::driver_info is not used in the kernel. The structure is > also not part of API/ABI, so the unused member can just be dropped. > > Signed-off-by: Uwe Kleine-König (The Capable Hub) <[email protected]> > --- > Hello, > > Sashiko was quick to identify two issues in my patch. Before someone > gets around to review v1 by hand, here is a v2 addressing Sashiko's > concerns: > > - remove the typedef for kernel_ulong_t > - s/device_info/driver_info/ in the commit log > > Thanks > Uwe > > include/linux/device-id/ap.h | 2 -- > 1 file changed, 2 deletions(-) Applied, thank you!