Re: [PATCH v4 7/9] PCI: Make pci_match_one_device() match on ID instead of device

Bjorn Helgaas <[email protected]>
Newsgroups org.kernel.vger.linux-scsi,dev.linux.lists.driver-core,org.freedesktop.lists.dri-devel,org.kernel.vger.linux-ide,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pci,org.kernel.vger.netdev
Message-ID <20260728162432.GA1322140@bhelgaas>
[cc->to: Dave, Vaibhav, Jens, Greg, GOTO, YOKOTA: possible acks?
series: https://lore.kernel.org/all/[email protected]]

On Sat, Jul 25, 2026 at 01:17:50PM +0100, Gary Guo wrote:
> On Fri Jul 24, 2026 at 11:29 PM BST, Bjorn Helgaas wrote:
> > On Thu, Jul 23, 2026 at 11:00:46PM +0100, Gary Guo wrote:
> >> PCI dynamic ID needs to match IDs against a new ID to see if it already
> >> exists. Existing APIs can only match IDs against devices, causing the
> >> dynamic ID insertion code to create a temporary device only for matching
> >> purpose. Rename pci_match_one_device() to pci_match_one_id() so it can be
> >> used for this purpose instead; add a pci_id_from_device() helper to make it
> >> easy to convert users.
> >
> > s/causing the ... code to create/so the ... code creates/
> > s/purpose/purposes/
> >
> >> Similarly, convert pci_match_id() to do_pci_match_id(). But keep the
> >> existing API because there are many users.
> >> 
> >> Reviewed-by: Danilo Krummrich <[email protected]>
> >> Signed-off-by: Gary Guo <[email protected]>
> >
> > Reviewed-by: Bjorn Helgaas <[email protected]>
> > Acked-by: Bjorn Helgaas <[email protected]>
> >
> > What's the merge strategy?  If these all need to be merged
> > together, feel free to include the PCI patches whereever you merge
> > the series.
> 
> I think the series should be merged together, as I consider the
> driver changes included in this series being "fixing the users".
> 
> The series should probably be taken via the PCI tree. I suppose one
> can also argue that the lifetime issue with device IDs isn't unique
> to PCI bus so this can also be considered driver-core material, but
> given that Greg has already taken the USB fixes via the USB tree the
> only unfixed bus left is PCI.
> 
> So unless Danilo thinks otherwise I'd suggest the series be taken as
> a whole via PCI.

I'm happy to take via PCI.  It would be great to have acks/reviewed-by
from the non-PCI maintainers:

  David Airlie <[email protected]> (agp)

  Vaibhav Gupta <[email protected]> (tpci200)
  Jens Taprogge <[email protected]> (tpci200)
  Greg Kroah-Hartman <[email protected]> (tpci200)

  GOTO Masanori <[email protected]> (nsp32)
  YOKOTA Hiroshi <[email protected]> (nsp32)
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.