Re: [PATCH] scsi: leapraid: standardize NCQ priority sysfs attributes
Damien Le Moal <[email protected]>
| Newsgroups | org.kernel.vger.linux-scsi |
|---|---|
| Organization | Western Digital Research |
| Message-ID | <[email protected]> |
On 8/14/26 17:14, Dongdong Hao wrote: > Replace the earlier LeapRAID ncq_cmd_prio_enable > attribute with the standard sas_ncq_prio_supported and > sas_ncq_prio_enable names documented in > Documentation/ABI/testing/sysfs-block-device, and rename > the per-device NCQ priority state to match. > > The earlier ncq_cmd_prio_enable name has not yet been > established as part of a released userspace ABI, so no > compatibility alias is needed. > > For LeapRAID, sas_ncq_prio_enable is backed by the > driver's per-device NCQ priority state and controls > whether RT-class I/O requests are issued with command > priority on supported SATA devices. > > Update leapraid.rst to describe the standard attribute > names and paths, and clean up the surrounding RST text > for consistency with kernel documentation style. > > Also switch the capability check from open-coded VPD > page 0x89 parsing to sas_ata_ncq_prio_supported(), use > kstrtobool() for the enable path, and expose the NCQ > priority attributes only for SATA devices using > LeapRAID's target-private SAS device state. > > Signed-off-by: Dongdong Hao <[email protected]> Your commit message lines are very short. Please use up to 75 chars per line. Other than that, looks OK. Reviewed-by: Damien Le Moal <[email protected]> -- Damien Le Moal Western Digital Research