Re: [PATCH v2] scsi: leapraid: standardize NCQ priority sysfs attributes

Hannes Reinecke <[email protected]>
Newsgroups org.kernel.vger.linux-scsi
Message-ID <[email protected]>
On 8/14/26 11:05 AM, Dongdong Hao wrote:
> Replace the earlier LeapRAID ncq_cmd_prio_enable attribute with the
> standard sas_ncq_prio_supported and sas_ncq_prio_enable names documented
> in Documentation/ABI/testing/sysfs-block-device, and rename the
> per-device NCQ priority state to match.
> 
> The earlier ncq_cmd_prio_enable name has not yet been established as part
> of a released userspace ABI, so no compatibility alias is needed.
> 
> For LeapRAID, sas_ncq_prio_enable is backed by the driver's per-device
> NCQ priority state and controls whether RT-class I/O requests are issued
> with command priority on supported SATA devices.
> 
> Update leapraid.rst to describe the standard attribute names and paths,
> and clean up the surrounding RST text for consistency with kernel
> documentation style.
> 
> Also switch the capability check from open-coded VPD page 0x89 parsing to
> sas_ata_ncq_prio_supported(), use kstrtobool() for the enable path, and
> expose the NCQ priority attributes only for SATA devices using LeapRAID's
> target-private SAS device state.
> 
> Reviewed-by: Damien Le Moal <[email protected]>
> Signed-off-by: Dongdong Hao <[email protected]>
> ---
> Changes in v2:
>   - Reflow commit message lines to fit within 75 columns.
>   - No functional change.
> 
Reviewed-by: Hannes Reinecke <[email protected]>

Cheers,

Hannes
-- 
Dr. Hannes Reinecke                  Kernel Storage Architect
[email protected]                                +49 911 74053 688
SUSE Software Solutions GmbH, Frankenstr. 146, 90461 Nürnberg
HRB 36809 (AG Nürnberg), GF: I. Totev, A. McDonald, W. Knoblich
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.