Re: [PATCH 00/15] tracepoint: Avoid double static_branch evaluation at guarded call sites
Mathieu Desnoyers <[email protected]> Thu, 12 Mar 2026 11:57:17 -0400
| Newsgroups | org.kernel.vger.linux-sctp,org.freedesktop.lists.amd-gfx,org.freedesktop.lists.dri-devel,org.kernel.vger.bpf,org.kernel.vger.io-uring,org.kernel.vger.linux-btrfs,org.kernel.vger.linux-i2c,org.kernel.vger.linux-input,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pm,org.kernel.vger.linux-scsi,org.kernel.vger.linux-spi,org.kernel.vger.linux-trace-kernel,org.kernel.vger.netdev |
|---|---|
| Message-ID | <[email protected]> |
On 2026-03-12 11:54, Peter Zijlstra wrote: > On Thu, Mar 12, 2026 at 11:49:23AM -0400, Mathieu Desnoyers wrote: >> On 2026-03-12 11:40, Steven Rostedt wrote: >>> On Thu, 12 Mar 2026 11:28:07 -0400 >>> Mathieu Desnoyers <[email protected]> wrote: >>> >>>>> Note, Vineeth came up with the naming. I would have done "do" but when I >>>>> saw "invoke" I thought it sounded better. >>>> >>>> It works as long as you don't have a tracing subsystem called >>>> "invoke", then you get into identifier clash territory. >>> >>> True. Perhaps we should do the double underscore trick. >>> >>> Instead of: trace_invoke_foo() >>> >>> use: trace_invoke__foo() >>> >>> >>> Which will make it more visible to what the trace event is. >>> >>> Hmm, we probably should have used: trace__foo() for all tracepoints, as >>> there's still functions that are called trace_foo() that are not >>> tracepoints :-p >> >> One certain way to eliminate identifier clash would be to go for a >> prefix to "trace_", e.g. > > Oh, I know!, call them __do_trace_##foo(). > > /me runs like hell So s/__do_trace_/do_trace_/g and call it a day ? Thanks, Mathieu -- Mathieu Desnoyers EfficiOS Inc. https://www.efficios.com