Re: [PATCH 00/15] tracepoint: Avoid double static_branch evaluation at guarded call sites
Vineeth Remanan Pillai <[email protected]> Wed, 18 Mar 2026 06:58:46 -0400
| Newsgroups | org.kernel.vger.linux-sctp,org.freedesktop.lists.amd-gfx,org.freedesktop.lists.dri-devel,org.kernel.vger.bpf,org.kernel.vger.io-uring,org.kernel.vger.linux-btrfs,org.kernel.vger.linux-i2c,org.kernel.vger.linux-input,org.kernel.vger.linux-kernel,org.kernel.vger.linux-pm,org.kernel.vger.linux-scsi,org.kernel.vger.linux-spi,org.kernel.vger.linux-trace-kernel,org.kernel.vger.netdev |
|---|---|
| Message-ID | <CAO7JXPgbERfc_P+aPFB1+nR5ua3mZGbhdkbxCr0TFR4Cr6Khuw@mail.gmail.com> |
On Tue, Mar 17, 2026 at 12:02 PM Mathieu Desnoyers <[email protected]> wrote: > > On 2026-03-17 12:00, Steven Rostedt wrote: > > On Fri, 13 Mar 2026 10:02:32 -0400 > > Vineeth Remanan Pillai <[email protected]> wrote: > > > >>> > >>> Perhaps: call_trace_foo() ? > >>> > >> call_trace_foo has one collision with the tracepoint > >> sched_update_nr_running and a function > >> call_trace_sched_update_nr_running. I had considered this and later > >> moved to trace_invoke_foo() because of the collision. But I can rename > >> call_trace_sched_update_nr_running to something else if call_trace_foo > >> is the general consensus. > > > > OK, then lets go with: trace_call__foo() > > > > The double underscore should prevent any name collisions. > > > > Does anyone have an objections? > I'm OK with it. > Great thanks! I shall send a v2 with s/trace_invoke_foo/trace_call__foo/ soon. Thanks, Vineeth