Re: [PATCH v3 6/9] x86/entry/vdso: include GNU_PROPERTY and GNU_STACK PHDRs

"H. Peter Anvin" <[email protected]>
Newsgroups org.kernel.vger.linux-sgx,org.kernel.vger.linux-kernel,org.kvack.linux-mm
Message-ID <[email protected]>
On 2025-11-13 11:09, Andrew Cooper wrote:
> 
> Almost all of these hunks look to be whitespace changes only.  Was that
> intentional?  It certainly makes it harder to read.
> 

It is intentional; although it adds to the patch it tidies up the file itself.

>>  	.altinstructions	: { *(.altinstructions) }	:text
>>  	.altinstr_replacement	: { *(.altinstr_replacement) }	:text
>> @@ -87,15 +84,23 @@ SECTIONS
>>   * Very old versions of ld do not recognize this name token; use the constant.
>>   */
>>  #define PT_GNU_EH_FRAME	0x6474e550
>> +#define PT_GNU_STACK	0x6474e551
>> +#define PT_GNU_PROPERTY	0x6474e553
>>  
>>  /*
>>   * We must supply the ELF program headers explicitly to get just one
>>   * PT_LOAD segment, and set the flags explicitly to make segments read-only.
>> - */
>> +*/
> 
> This looks like it wants undoing too.

OK, fair.

> That said, I do strongly agree with the reasoning behind this patch.

Thanks.

	-hpa
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.