Re: [PATCH v2 02/13] mm: rename vma_flag_test/set_atomic() to vma_test/set_atomic_flag()
Pedro Falcato <[email protected]>
| Newsgroups | org.kernel.vger.linux-sgx,dev.linux.lists.ntfs3,dev.linux.lists.nvdimm,org.freedesktop.lists.dri-devel,org.freedesktop.lists.intel-gfx,org.kernel.vger.keyrings,org.kernel.vger.linux-cxl,org.kernel.vger.linux-ext4,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel,org.kernel.vger.linux-security-module,org.kernel.vger.linux-xfs,org.kvack.linux-mm,org.ozlabs.lists.linux-erofs |
|---|---|
| Message-ID | <5pqsv3quguk6mwxywdqpvkcxhmqjoupqq44pserucrlelnyvnc@tkwpixdhcw5i> |
On Thu, Jan 22, 2026 at 04:06:11PM +0000, Lorenzo Stoakes wrote: > In order to stay consistent between functions which manipulate a vm_flags_t > argument of the form of vma_flags_...() and those which manipulate a > VMA (in this case the flags field of a VMA), rename > vma_flag_[test/set]_atomic() to vma_[test/set]_atomic_flag(). > > This lays the groundwork for adding VMA flag manipulation functions in a > subsequent commit. > > Signed-off-by: Lorenzo Stoakes <[email protected]> Reviewed-by: Pedro Falcato <[email protected]> -- Pedro