Re: [PATCH 16/30] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
SJ Park <[email protected]> Mon, 29 Jun 2026 17:11:59 -0700
| Newsgroups | org.kernel.vger.linux-sgx,dev.linux.lists.damon,dev.linux.lists.iommu,dev.linux.lists.nvdimm,org.freedesktop.lists.dri-devel,org.kernel.vger.kvm,org.kernel.vger.linux-arm-msm,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel,org.kernel.vger.linux-parisc,org.kernel.vger.linux-perf-users,org.kernel.vger.linux-tegra,org.kernel.vger.linux-trace-kernel,org.kvack.linux-mm |
|---|---|
| Message-ID | <[email protected]> |
On Mon, 29 Jun 2026 13:23:27 +0100 Lorenzo Stoakes <[email protected]> wrote: > There are many instances in which linear_page_index() (as well as > linear_page_delta()) is open-coded, which is confusing and inconsistent. > > Additionally, vma->vm_pgoff doesn't necessarily make it clear that this is > the page offset of the start of the VMA range. > > Doing so also aids greppability. > > So use vma_start_pgoff() in favour of directly accessing vma->vm_pgoff, and > linear_page_index() where we can. > > This also lays the ground for future changes which will add an anonymous > page offset in order to be able to index MAP_PRIVATE-file backed anon > folios in terms of their virtual page offset. > > No functional change intended. > > Signed-off-by: Lorenzo Stoakes <[email protected]> > --- > include/linux/huge_mm.h | 1 + > include/linux/hugetlb.h | 3 +-- > include/linux/pagemap.h | 2 +- > mm/damon/vaddr.c | 5 +++-- I quickly looked only the DAMON part. Looks nice and cleaner, thank you! Reviewed-by: SJ Park <[email protected]> Thanks, SJ [...]