Re: [PATCH 09/30] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Lorenzo Stoakes <[email protected]> Tue, 30 Jun 2026 16:49:45 +0100
| Newsgroups | org.kernel.vger.linux-sgx,dev.linux.lists.damon,dev.linux.lists.iommu,dev.linux.lists.nvdimm,org.freedesktop.lists.dri-devel,org.kernel.vger.kvm,org.kernel.vger.linux-arm-msm,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel,org.kernel.vger.linux-parisc,org.kernel.vger.linux-perf-users,org.kernel.vger.linux-tegra,org.kernel.vger.linux-trace-kernel,org.kvack.linux-mm |
|---|---|
| Message-ID | <akPlUrNWzl1ZPw1S@lucifer> |
On Tue, Jun 30, 2026 at 11:46:46AM -0400, Gregory Price wrote: > On Mon, Jun 29, 2026 at 01:23:20PM +0100, Lorenzo Stoakes wrote: > > Similar to what we did with mapping_interval_tree*(), let's declare > > anon_vma_interval_tree*() in terms of anon_vma rather than rb_root_cached. > > > > In each case the rb tree referenced is &anon_vma->rb_root, so just pass > > anon_vma and the functions can figure this out themselves. > > > > Additionally, rename 'node' to 'avc', 'index' to 'pgoff_start', and 'last' > > to 'pgoff_last' to make clear what is being passed. > > > > would it be possible to split the pure rename changes out from the > changed function declarations? It's hard to pick out this as something > that needs to be looked at as more than just a %s/x/y/ Hmmm do I have to? :P I mean sure I can on a respin potentially, but it is a pretty trivial change? Just mechnically as above. > > > +void anon_vma_interval_tree_insert(struct anon_vma_chain *avc, > > + struct anon_vma *anon_vma) > ... > > - __anon_vma_interval_tree_insert(node, root); > > + __anon_vma_interval_tree_insert(avc, &anon_vma->rb_root); > > an annoying request, sorry :)) well it's ok I've made enough annoying requests of my own on review :) > > ~Gregory Cheers, Lorenzo