Re: [PATCH v4 02/35] compiler-context-analysis: Add infrastructure for Context Analysis with Clang

Peter Zijlstra <[email protected]> Fri, 12 Dec 2025 10:31:49 +0100
Newsgroups org.kernel.vger.linux-sparse,dev.linux.lists.llvm,org.kernel.vger.linux-crypto,org.kernel.vger.linux-doc,org.kernel.vger.linux-kbuild,org.kernel.vger.linux-kernel,org.kernel.vger.linux-security-module,org.kernel.vger.linux-wireless,org.kernel.vger.rcu,org.kvack.linux-mm
Message-ID <[email protected]>
On Thu, Dec 11, 2025 at 02:12:19PM +0100, Marco Elver wrote:

> What's a better name?

That must be the hardest question in programming; screw this P-vs-NP
debate :-)

> context_lock_struct -> and call it "context lock" rather than "context
> guard"; it might work also for things like RCU, PREEMPT, BH, etc. that
> aren't normal "locks", but could claim they are "context locks".
> 
> context_handle_struct -> "context handle" ...

Both work for me I suppose, although I think I have a slight preference
to the former: 'context_lock_struct'.

One other possibility is wrapping things like so:

#define define_context_struct(name) ... // the big thing

#define define_lock_struct(name) define_context_struct(name)