Re: [PATCH] gpio: Use IRQ trigger mask helpers

Linus Walleij <[email protected]> Thu, 6 Aug 2026 23:50:00 +0200
Newsgroups org.kernel.vger.linux-tegra,dev.linux.lists.imx,org.infradead.lists.linux-arm-kernel,org.infradead.lists.linux-mediatek,org.kernel.vger.linux-gpio,org.kernel.vger.linux-kernel,org.kernel.vger.linux-omap
Message-ID <CAD++jLmFruzsuSCgzKCZoy63dgTPi=Hci-xgj76315ht9ttFyQ@mail.gmail.com>
On Sun, Aug 2, 2026 at 4:11=E2=80=AFPM Maulik Shah <[email protected]=
m.com> wrote:

> Use IRQ_TYPE_LEVEL_MASK and IRQ_TYPE_EDGE_BOTH instead of open-coded
> trigger type combinations in irqchip callbacks.
>
> No functional change intended.
>
> Assisted-by: Claude:claude-sonnet-5
> Signed-off-by: Maulik Shah <[email protected]>

Reviewed-by: Linus Walleij <[email protected]>

Yours,
Linus Walleij