[PATCH 0/2] dmaengine: rename dma_chan::dev to dma_chan::chan_dev for clarity

[email protected] Wed, 12 Aug 2026 17:24:07 -0400
Newsgroups org.kernel.vger.linux-tegra,dev.linux.lists.imx,dev.linux.lists.linux-sunxi,org.infradead.lists.linux-arm-kernel,org.kernel.vger.dmaengine,org.kernel.vger.linux-kernel,org.kernel.vger.linux-mips,org.kernel.vger.linux-trace-kernel
Message-ID <[email protected]>
The current dma_chan structure contains both "device" and "dev". So

    chan->device->dev refers to the DMA engine device.
    chan->dev->device refers to the per-channel device instance.

Their similar naming makes the distinction unclear and increases reader
confusion.

Add union dma_chan::chan_dev to make its purpose explicit and clearly
identify it as the per-channel device. After all user switch to chan_dev,
union and dma_chan::dev will be removed.

Update the kernel-doc accordingly. Besides its sysfs usage, the per-channel
device is also used by some DMA engine drivers for IOMMU mapping and
therefore deserves a more accurate description.

1st patch use existing helper dma_chan_name() to reduce rename difference.
2nd rename drivers/dma

Need following patch to clean other dma engineer driver, which is not
in drivers/dma

After complete all rename work, dma_chan::dev can be removed.

Signed-off-by: Frank Li <[email protected]>
---
Frank Li (2):
      dmaengine: use dma_chan_name() helper to get per-channel device name
      dmaengine: add union chan_dev for dma_chan::dev for clarity

 drivers/dma/arm-dma350.c                       |  2 +-
 drivers/dma/at_hdmac.c                         |  2 +-
 drivers/dma/at_xdmac.c                         |  2 +-
 drivers/dma/dma-jz4780.c                       | 10 ++---
 drivers/dma/dmaengine.c                        | 34 ++++++++---------
 drivers/dma/dw-axi-dmac/dw-axi-dmac-platform.c |  2 +-
 drivers/dma/dw-axi-dmac/dw-axi-dmac.h          |  4 +-
 drivers/dma/dw/core.c                          |  2 +-
 drivers/dma/ep93xx_dma.c                       |  2 +-
 drivers/dma/idma64.c                           |  4 +-
 drivers/dma/loongson/loongson1-apb-dma.c       |  2 +-
 drivers/dma/loongson/loongson2-apb-cmc-dma.c   |  4 +-
 drivers/dma/loongson/loongson2-apb-dma.c       |  4 +-
 drivers/dma/mmp_pdma.c                         |  2 +-
 drivers/dma/nbpfaxi.c                          |  2 +-
 drivers/dma/owl-dma.c                          |  2 +-
 drivers/dma/pch_dma.c                          |  2 +-
 drivers/dma/pxa_dma.c                          | 52 +++++++++++++-------------
 drivers/dma/st_fdma.c                          |  2 +-
 drivers/dma/stm32/stm32-dma.c                  |  4 +-
 drivers/dma/stm32/stm32-dma3.c                 |  8 ++--
 drivers/dma/stm32/stm32-mdma.c                 |  4 +-
 drivers/dma/sun6i-dma.c                        |  2 +-
 drivers/dma/switchtec_dma.c                    | 14 +++----
 drivers/dma/tegra186-gpc-dma.c                 |  4 +-
 drivers/dma/tegra20-apb-dma.c                  |  2 +-
 drivers/dma/ti/k3-udma.c                       |  6 +--
 drivers/dma/timb_dma.c                         |  2 +-
 include/linux/dmaengine.h                      | 18 ++++++---
 include/trace/events/tegra_apb_dma.h           |  6 +--
 30 files changed, 107 insertions(+), 99 deletions(-)
---
base-commit: 28d012efb4327f9c75d5e042a7c91e9a542efa98
change-id: 20260812-dma-chan_dev-rename-66263ac5eac9

Best regards,
--  
Frank Li <[email protected]>