Re: [PATCH v4 14/39] perf/x86: Rename get_segment_base() and make it global
Peter Zijlstra <[email protected]>
| Newsgroups | org.kernel.vger.linux-toolchains,org.kernel.vger.linux-kernel,org.kernel.vger.linux-perf-users,org.kernel.vger.linux-trace-kernel |
|---|---|
| Message-ID | <[email protected]> |
On Tue, Jan 21, 2025 at 06:31:06PM -0800, Josh Poimboeuf wrote: > get_segment_base() will be used by the unwind_user code, so make it > global and rename it so it doesn't conflict with a KVM function of the > same name. Should it not also get moved out of the perf code in this case?