[PATCH] libtracefs utest: Update kprobe test to use filename_mkdirat
Steven Rostedt <[email protected]> Fri, 29 May 2026 15:30:23 -0400
| Newsgroups | org.kernel.vger.linux-trace-devel |
|---|---|
| Message-ID | <20260529153023.440b966c@fedora> |
From: Steven Rostedt <[email protected]> The function do_mkdirat was renamed to filename_mkdirat. Ideally, this would check if the filename_mkdirat exists and if not, fallback to do_mkdirat. But that would just add complexity to a test that should be called on the most recent kernels anyway. If it does become an issue, we can add the complexity and make it more robust. Perhaps a check should be done to make sure each function exists before testing it. Signed-off-by: Steven Rostedt <[email protected]> --- utest/tracefs-utest.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/utest/tracefs-utest.c b/utest/tracefs-utest.c index e3ff215..05cbc95 100644 --- a/utest/tracefs-utest.c +++ b/utest/tracefs-utest.c @@ -2289,7 +2289,7 @@ static bool check_probes(struct probe_test *probes, int count, static void test_kprobes_instance(struct tracefs_instance *instance) { struct probe_test ktests[] = { - { TRACEFS_DYNEVENT_KPROBE, "p", NULL, "mkdir", "do_mkdirat", "path=+u0($arg2):ustring" }, + { TRACEFS_DYNEVENT_KPROBE, "p", NULL, "mkdir", "filename_mkdirat", "path=+u0($arg2):ustring" }, { TRACEFS_DYNEVENT_KPROBE, "p", NULL, "close", "close_fd", NULL }, { TRACEFS_DYNEVENT_KPROBE, "p", "ptest", "open2", "do_sys_openat2", "file=+u0($arg2):ustring flags=+0($arg3):x64" }, @@ -2634,7 +2634,7 @@ static void test_multi_probes_instance(struct tracefs_instance *instance) "file=+0($filename):ustring" }, { TRACEFS_DYNEVENT_EPROBE, "e", "etest", "sopen_out", "syscalls.sys_exit_openat", "res=$ret:u64" }, - { TRACEFS_DYNEVENT_KPROBE, "p", NULL, "mkdir", "do_mkdirat", "path=+u0($arg2):ustring" }, + { TRACEFS_DYNEVENT_KPROBE, "p", NULL, "mkdir", "filename_mkdirat", "path=+u0($arg2):ustring" }, { TRACEFS_DYNEVENT_KPROBE, "p", NULL, "close", "close_fd", NULL }, { TRACEFS_DYNEVENT_KPROBE, "p", "ptest", "open2", "do_sys_openat2", "file=+u0($arg2):ustring flags=+0($arg3):x64" }, -- 2.51.0