Re: [PATCH v2 02/18] xfs: convert iomap ops to ->iomap_next()
Christoph Hellwig <[email protected]>
| Newsgroups | org.kernel.vger.linux-xfs,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
On Fri, Jul 17, 2026 at 10:55:52AM -0700, Darrick J. Wong wrote: > > Going back to this... "iomap_iter_fn iomap_iter" doesn't feel quite > > right. I think there's too much naming collision with iomap_iter() and > > struct iomap_iter, and I like how in general ->next() matches the > > orthodox naming scheme for advancing an iterator. I think > > "iomap_iter_next_fn next" would be the best of both worlds - I'll > > change it to this for v3. But if you don't agree with this, please let > > me know. > > Fine by me :) Same here.