Re: [PATCH v2] xfs: use kmalloc_objs() instead of kmalloc() in xfs_da_grow_inode_int
Carlos Maiolino <[email protected]>
| Newsgroups | org.kernel.vger.linux-xfs,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <178463068845.324722.5237612936067528088.b4-ty@b4> |
On Thu, 16 Jul 2026 15:48:12 -0600, Cihan Karadag wrote:
> Convert open-coded kmalloc() multiplication to the modern kmalloc_objs()
> interface to improve type safety and prevent potential integer
> overflows.
>
> No functional changes are intended.
>
>
> [...]
Applied to for-next, thanks!
[1/1] xfs: use kmalloc_objs() instead of kmalloc() in xfs_da_grow_inode_int
commit: 97f34168769238b1fe4412229c99f1a78364f6f9
Best regards,
--
Carlos Maiolino <[email protected]>