Re: [PATCH 03/12] xfs: split out a lower-level xfs_buf_get_map helper from xfs_find_get_buf

Christoph Hellwig <[email protected]> Tue, 28 Jul 2026 06:39:18 +0200
Newsgroups org.kernel.vger.linux-xfs
Message-ID <[email protected]>
On Fri, Jul 24, 2026 at 09:44:27AM -0700, Darrick J. Wong wrote:
> I like the idea of factoring this out, but I can't tell from the names
> what's the difference between xfs_find_get_buf and xfs_buf_get_map.
> 
> I might have called the inner function __xfs_buf_get or something.
> Dunno, don't care to bikeshed this.

Heh.  __xfs_buf_get just keep the bad naming of xfs_buf_get  But
I can add a __-prefix to mark it more internal.