Re: [PATCH v2 40/53] objtool: Consolidate file decoding into decode_file()

Miroslav Benes <[email protected]>
Newsgroups org.kernel.vger.live-patching,org.kernel.vger.linux-kernel
Message-ID <177798141795.9921.425193304582000754.b4-review@b4>
On Thu, 30 Apr 2026 21:08:28 -0700, Josh Poimboeuf <[email protected]> wrote:
> decode_sections() relies on CFI and cfi_hash initialization done
> separately in check(), making it unusable outside of check().
> 
> Consolidate the initialization into decode_sections() and rename it to
> decode_file(), and make it global along with free_insns() and
> insn_reloc() for use by other objtool components -- namely, the checksum
> code which will be moving to another file.
> 
> [...]

Reviewed-by: Miroslav Benes <[email protected]>

-- 
Miroslav
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.