Re: [PATCH v3 04/21] arm64: Rename TRAMP_VALIAS -> TRAMP_VALIAS_ASM in asm-offsets
Song Liu <[email protected]>
| Newsgroups | org.kernel.vger.live-patching,org.infradead.lists.linux-arm-kernel,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <CAPhsuW4G5H979FCvk0tfebOxjBcMak5n3Cx8YB6yhtSLaJiGzw@mail.gmail.com> |
On Tue, May 12, 2026 at 8:34 PM Josh Poimboeuf <[email protected]> wrote: > > Rename the asm-offsets TRAMP_VALIAS macro to TRAMP_VALIAS_ASM, following > the naming convention already used by PIE_E0_ASM and PIE_E1_ASM. This > disambiguates the asm-offsets-generated constant from the C macro of the > same name defined in fixmap.h and vectors.h. > > This is needed by a later patch which adds new includes to asm-offsets.c > that would otherwise conflict with the C version. > > Signed-off-by: Josh Poimboeuf <[email protected]> Acked-by: Song Liu <[email protected]>