Re: [PATCH v2 5/8] riscv: stacktrace: introduce stack-bound tracking helpers
Shuai Xue <[email protected]> Wed, 3 Jun 2026 09:23:08 +0800
| Newsgroups | org.kernel.vger.live-patching,org.infradead.lists.linux-riscv,org.kernel.vger.linux-kernel,org.kernel.vger.linux-kselftest,org.kernel.vger.linux-perf-users,org.kernel.vger.linux-trace-kernel |
|---|---|
| Message-ID | <[email protected]> |
On 5/28/26 4:23 PM, Wang Han wrote: > A reliable unwinder needs to validate that every frame record it reads > is fully contained in a known kernel stack, and it needs to refuse to > walk back into a stack it has already left. Add the building blocks > for that: > > * struct stack_info / struct unwind_state in a new > asm/stacktrace/common.h, modelled on the arm64 reference > implementation. > * stackinfo_get_irq() / stackinfo_get_task() / stackinfo_get_overflow() > plus the corresponding on_*_stack() predicates in asm/stacktrace.h, > so callers can ask "is this object on stack X?" by stack kind > rather than open-coded address arithmetic. > * unwind_init_common(), unwind_find_stack() and > unwind_consume_stack() helpers that enforce the > forward-progress-only invariant required for reliability. > > No existing user is wired up to these helpers in this commit; the > unwinder switch comes in a follow-up. The header changes leave > on_thread_stack() with the same semantics as before, just expressed in > terms of the new helpers. > > Signed-off-by: Wang Han <[email protected]> > --- > arch/riscv/include/asm/stacktrace.h | 65 ++++++++- > arch/riscv/include/asm/stacktrace/common.h | 159 +++++++++++++++++++++ > 2 files changed, 222 insertions(+), 2 deletions(-) > create mode 100644 arch/riscv/include/asm/stacktrace/common.h > > diff --git a/arch/riscv/include/asm/stacktrace.h b/arch/riscv/include/asm/stacktrace.h > index b1495a7e06ce..bc87c4940379 100644 > --- a/arch/riscv/include/asm/stacktrace.h > +++ b/arch/riscv/include/asm/stacktrace.h > @@ -3,8 +3,13 @@ > #ifndef _ASM_RISCV_STACKTRACE_H > #define _ASM_RISCV_STACKTRACE_H > > +#include <linux/percpu.h> > #include <linux/sched.h> > +#include <linux/sched/task_stack.h> > + > +#include <asm/irq_stack.h> > #include <asm/ptrace.h> > +#include <asm/stacktrace/common.h> > > struct stackframe { > unsigned long fp; > @@ -16,14 +21,70 @@ extern void notrace walk_stackframe(struct task_struct *task, struct pt_regs *re > extern void dump_backtrace(struct pt_regs *regs, struct task_struct *task, > const char *loglvl); > > -static inline bool on_thread_stack(void) > +/* > + * IRQ stack accessors > + */ > +static inline struct stack_info stackinfo_get_irq(void) > +{ > + unsigned long low = (unsigned long)raw_cpu_read(irq_stack_ptr); > + unsigned long high = low + IRQ_STACK_SIZE; > + > + return (struct stack_info) { > + .low = low, > + .high = high, > + }; > +} > + > +static inline bool on_irq_stack(unsigned long sp, unsigned long size) > +{ > + struct stack_info info = stackinfo_get_irq(); > + > + return stackinfo_on_stack(&info, sp, size); > +} > + > +/* > + * Task stack accessors > + */ > +static inline struct stack_info stackinfo_get_task(const struct task_struct *tsk) > { > - return !(((unsigned long)(current->stack) ^ current_stack_pointer) & ~(THREAD_SIZE - 1)); > + unsigned long low = (unsigned long)task_stack_page(tsk); > + unsigned long high = low + THREAD_SIZE; > + > + return (struct stack_info) { > + .low = low, > + .high = high, > + }; > +} > + > +static inline bool on_task_stack(const struct task_struct *tsk, > + unsigned long sp, unsigned long size) > +{ > + struct stack_info info = stackinfo_get_task(tsk); > + > + return stackinfo_on_stack(&info, sp, size); > } > > +/* > + * Cast is necessary since current->stack is an opaque ptr. > + */ > +#define on_thread_stack() (on_task_stack(current, current_stack_pointer, 1)) > > +/* > + * Overflow stack accessors > + */ > #ifdef CONFIG_VMAP_STACK > DECLARE_PER_CPU(unsigned long [OVERFLOW_STACK_SIZE/sizeof(long)], overflow_stack); > + > +static inline struct stack_info stackinfo_get_overflow(void) > +{ > + unsigned long low = (unsigned long)raw_cpu_ptr(overflow_stack); > + unsigned long high = low + OVERFLOW_STACK_SIZE; > + > + return (struct stack_info) { > + .low = low, > + .high = high, > + }; > +} > #endif /* CONFIG_VMAP_STACK */ > > #endif /* _ASM_RISCV_STACKTRACE_H */ > diff --git a/arch/riscv/include/asm/stacktrace/common.h b/arch/riscv/include/asm/stacktrace/common.h > new file mode 100644 > index 000000000000..87d6d40672f3 > --- /dev/null > +++ b/arch/riscv/include/asm/stacktrace/common.h > @@ -0,0 +1,159 @@ > +/* SPDX-License-Identifier: GPL-2.0-only */ > +/* > + * RISC-V common stack unwinder types and helpers. > + * > + * See: arch/arm64/include/asm/stacktrace/common.h for the reference > + * implementation. > + * > + * Copyright (C) 2024 Nit: The new common.h carries "Copyright (C) 2024", but this is a 2026 submission. Reviewed-by: Shuai Xue <[email protected]> Thanks. Shuai