Re: [PATCH v3 04/21] arm64: Rename TRAMP_VALIAS -> TRAMP_VALIAS_ASM in asm-offsets
Miroslav Benes <[email protected]> Wed, 01 Jul 2026 13:54:41 +0200
| Newsgroups | org.kernel.vger.live-patching,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <178290688141.34581.8116654132662243314.b4-review@b4> |
On Tue, 12 May 2026 20:34:00 -0700, Josh Poimboeuf <[email protected]> wrote: > Rename the asm-offsets TRAMP_VALIAS macro to TRAMP_VALIAS_ASM, following > the naming convention already used by PIE_E0_ASM and PIE_E1_ASM. This > disambiguates the asm-offsets-generated constant from the C macro of the > same name defined in fixmap.h and vectors.h. > > This is needed by a later patch which adds new includes to asm-offsets.c > that would otherwise conflict with the C version. > > [...] Reviewed-by: Miroslav Benes <[email protected]> -- Miroslav