Re: [PATCH net-next] net: libwx: rename wx_pf_flags to wx_flags
Breno Leitao <[email protected]>
| Newsgroups | org.kernel.vger.netdev |
|---|---|
| Message-ID | <[email protected]> |
On Tue, Aug 11, 2026 at 02:50:38PM +0800, Jiawen Wu wrote: > The flags defined in `enum wx_pf_flags` and its terminator > `WX_PF_FLAGS_NBITS` were originally named with a "PF" (Physical Function) > prefix. However, these flags are not exclusive to PFs and are also > utilized by Virtual Functions (VFs). > > Rename the enumeration to `enum wx_flags` and the bit count to > `WX_FLAGS_NBITS` to accurately reflect their shared usage across both PF > and VF drivers, and to prevent potential confusion. > > Signed-off-by: Jiawen Wu <[email protected]> Reviewed-by: Breno Leitao <[email protected]>