[PATCH net-next v2 1/2] dt-bindings: net: dsa: realtek: add RTL8365MB power supplies
Oleksij Rempel <[email protected]>
| Newsgroups | org.kernel.vger.netdev,org.kernel.vger.linux-devicetree,org.kernel.vger.linux-kernel |
|---|---|
| Message-ID | <[email protected]> |
Document the RTL8365MB power rails as optional supplies. They are optional because the rails are often always-on; some designs break them out for granular hwmon monitoring and regulator control. They are scoped to realtek,rtl8365mb: different Realtek switch families use different power-rail naming schemes, so these rails do not apply to other families such as realtek,rtl8366rb (VDDA/VDD_CORE/VDDIO/...). Signed-off-by: Oleksij Rempel <[email protected]> --- .../devicetree/bindings/net/dsa/realtek.yaml | 25 +++++++++++++++++++ 1 file changed, 25 insertions(+) diff --git a/Documentation/devicetree/bindings/net/dsa/realtek.yaml b/Documentation/devicetree/bindings/net/dsa/realtek.yaml index 473facd87a62..98ea6072bd96 100644 --- a/Documentation/devicetree/bindings/net/dsa/realtek.yaml +++ b/Documentation/devicetree/bindings/net/dsa/realtek.yaml @@ -8,6 +8,30 @@ title: Realtek switches for unmanaged switches allOf: - $ref: dsa.yaml#/$defs/ethernet-ports + - if: + properties: + compatible: + contains: + const: realtek,rtl8365mb + then: + properties: + avddh-supply: + description: AVDDH high-voltage analog supply. + + avddl-supply: + description: AVDDL low-voltage analog supply. + + dvddio-supply: + description: DVDDIO digital I/O supply. + + dvddio1-supply: + description: DVDDIO_1 secondary digital I/O supply for the RGMII bank. + + dvddl-supply: + description: DVDDL digital core supply. + + pllvddl-supply: + description: PLLVDDL PLL analog supply. maintainers: - Linus Walleij <[email protected]> @@ -243,6 +267,7 @@ examples: platform { ethernet-switch { compatible = "realtek,rtl8365mb"; + avddh-supply = <&avddh>; mdc-gpios = <&gpio1 16 GPIO_ACTIVE_HIGH>; mdio-gpios = <&gpio1 17 GPIO_ACTIVE_HIGH>; reset-gpios = <&gpio5 0 GPIO_ACTIVE_LOW>; -- 2.47.3