Re: [PATCH 3/4] char: ipmi: use named initializers for acpi_device_id

Corey Minyard <[email protected]>
Newsgroups org.kernel.vger.platform-driver-x86,org.kernel.vger.linux-crypto,org.kernel.vger.linux-integrity,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On Fri, Aug 07, 2026 at 12:26:10PM +0100, Pawel Zalewski via B4 Relay wrote:
> From: "Pawel Zalewski (The Capable Hub)" <[email protected]>
> 
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base. Also
> drop explicitly setting fields to 0 where it is redundant.
> 
> While we are at it - unify the list terminator to have
> a single space between the brackets and no trailing
> comma.

This is fine, it's in my next tree for next release.

Thank you,

-corey

> 
> Signed-off-by: Pawel Zalewski (The Capable Hub) <[email protected]>
> ---
>  drivers/char/ipmi/ipmb_dev_int.c     | 4 ++--
>  drivers/char/ipmi/ipmi_si_platform.c | 4 ++--
>  drivers/char/ipmi/ipmi_ssif.c        | 4 ++--
>  3 files changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/drivers/char/ipmi/ipmb_dev_int.c b/drivers/char/ipmi/ipmb_dev_int.c
> index 680ff15c30ab..d576a77df927 100644
> --- a/drivers/char/ipmi/ipmb_dev_int.c
> +++ b/drivers/char/ipmi/ipmb_dev_int.c
> @@ -360,8 +360,8 @@ MODULE_DEVICE_TABLE(i2c, ipmb_id);
>  
>  #ifdef CONFIG_ACPI
>  static const struct acpi_device_id acpi_ipmb_id[] = {
> -	{ "IPMB0001", 0 },
> -	{},
> +	{ .id = "IPMB0001" },
> +	{ }
>  };
>  MODULE_DEVICE_TABLE(acpi, acpi_ipmb_id);
>  #endif
> diff --git a/drivers/char/ipmi/ipmi_si_platform.c b/drivers/char/ipmi/ipmi_si_platform.c
> index bdc481ce1302..fa221cbb4b3b 100644
> --- a/drivers/char/ipmi/ipmi_si_platform.c
> +++ b/drivers/char/ipmi/ipmi_si_platform.c
> @@ -387,8 +387,8 @@ static int acpi_ipmi_probe(struct platform_device *pdev)
>  }
>  
>  static const struct acpi_device_id acpi_ipmi_match[] = {
> -	{ "IPI0001", 0 },
> -	{ },
> +	{ .id = "IPI0001" },
> +	{ }
>  };
>  MODULE_DEVICE_TABLE(acpi, acpi_ipmi_match);
>  #else
> diff --git a/drivers/char/ipmi/ipmi_ssif.c b/drivers/char/ipmi/ipmi_ssif.c
> index 07f1d2327bb7..2361103c5edc 100644
> --- a/drivers/char/ipmi/ipmi_ssif.c
> +++ b/drivers/char/ipmi/ipmi_ssif.c
> @@ -2057,8 +2057,8 @@ static unsigned short *ssif_address_list(void)
>  
>  #ifdef CONFIG_ACPI
>  static const struct acpi_device_id ssif_acpi_match[] = {
> -	{ "IPI0001", 0 },
> -	{ },
> +	{ .id = "IPI0001" },
> +	{ }
>  };
>  MODULE_DEVICE_TABLE(acpi, ssif_acpi_match);
>  #endif
> 
> -- 
> 2.55.0
> 
>
lmpx.com only provides a reader for public news (NNTP) servers. It is not affiliated with the servers or forums shown here and is not responsible for the content of articles, which is written by their respective authors.