Re: [PATCH v5 4/7] rust: time: add Delta::to_jiffies() for timeout conversion
Andreas Hindborg <[email protected]> Thu, 06 Aug 2026 11:50:35 +0200
| Newsgroups | org.kernel.vger.rust-for-linux |
|---|---|
| Message-ID | <[email protected]> |
FUJITA Tomonori <[email protected]> writes: > From: FUJITA Tomonori <[email protected]> > > Add Delta<Nsec>::to_jiffies() conversion that rounds up so the > resulting timeout is never shorter than the requested span, clamps a > negative span to an immediate timeout, and saturates an overlong span > to the kernel's MAX_JIFFY_OFFSET "wait forever" value. > > Reviewed-by: Gary Guo <[email protected]> > Signed-off-by: FUJITA Tomonori <[email protected]> > --- > rust/kernel/time.rs | 21 +++++++++++++++++++++ > 1 file changed, 21 insertions(+) > > diff --git a/rust/kernel/time.rs b/rust/kernel/time.rs > index 9d65a6c1992a..5844ee985a7b 100644 > --- a/rust/kernel/time.rs > +++ b/rust/kernel/time.rs > @@ -551,6 +551,27 @@ pub fn as_millis_ceil(self) -> i64 { > } > } > > + /// Convert this span to a [`Delta<Jiffy>`] suitable for use as a timeout. > + /// > + /// The value is rounded up to the next whole jiffy, so the resulting > + /// timeout is never shorter than `self` (as `msecs_to_jiffies()` does). > + /// A negative span clamps to zero jiffies (an immediate timeout). Should we rename this to `to_jiffies_timeout` to indicate the clamping logic more clearly? I would expect a function with this name to have a negative `Delta<Nsec>` convert to a negative `Delta<Jiffy>`. Best regards, Andreas Hindborg