Re: systemd_generator_t vs systemd_generator_type
Chris PeBenito <[email protected]>
| Newsgroups | org.kernel.vger.selinux-refpolicy |
|---|---|
| Message-ID | <[email protected]> |
On 4/10/20 11:02 PM, Russell Coker wrote: > This combination of names is confusing. As a general rule I think we > shouldn't have a type name be a substring of an attribute name. Having an > attribute name as a substring of a type name is less of an issue but still > best avoided. > > /lib/systemd/system-generators/systemd-bless-boot-generator > /lib/systemd/system-generators/systemd-cryptsetup-generator > /lib/systemd/system-generators/systemd-debug-generator > /lib/systemd/system-generators/systemd-getty-generator > /lib/systemd/system-generators/systemd-hibernate-resume-generator > /lib/systemd/system-generators/systemd-rc-local-generator > /lib/systemd/system-generators/systemd-run-generator > /lib/systemd/system-generators/systemd-system-update-generator > /lib/systemd/system-generators/systemd-veritysetup-generator > /usr/lib/systemd/user-environment-generators/30-systemd-environment-d- > generator > > Above are the generators on my system that run as systemd_generator_t. Would > systemd_generator_generic_t/systemd_generator_generic_exec_t be an OK name? I'd accept a patch for this. -- Chris PeBenito