Re: [PATCH 5.15.y 6/6] KVM: x86/mmu: Rename __direct_map() to direct_map()
Sasha Levin <[email protected]>
| Newsgroups | org.kernel.vger.stable |
|---|---|
| Message-ID | <anS7OLhkr67ZDsx4@laps> |
On Thu, Aug 06, 2026 at 09:49:23PM +0530, Harshit Mogalapalli wrote: >Hi Sasha > >On 31/07/26 12:59 am, Sasha Levin wrote: >>From: David Matlack <[email protected]> >> >>[ Upstream commit 6c882ef4fc7bd99b67ad152e75428b669281c521 ] >> >>Rename __direct_map() to direct_map() since the leading underscores are >>unnecessary. This also makes the page fault handler names more >>consistent: kvm_tdp_mmu_page_fault() calls kvm_tdp_mmu_map() and >>direct_page_fault() calls direct_map(). >> >>Opportunistically make some trivial cleanups to comments that had to be >>modified anyway since they mentioned __direct_map(). Specifically, use >>"()" when referring to functions, and include kvm_tdp_mmu_map() among >>the various callers of disallowed_hugepage_adjust(). >> >>No functional change intended. >> >>Signed-off-by: David Matlack <[email protected]> >>Reviewed-by: Isaku Yamahata <[email protected]> >>Signed-off-by: Paolo Bonzini <[email protected]> >>Message-Id: <[email protected]> >>Signed-off-by: Paolo Bonzini <[email protected]> >>Stable-dep-of: 2abd5287f083 ("KVM: x86: Check for invalid/obsolete root *after* making MMU pages available") >>Signed-off-by: Sasha Levin <[email protected]> > >I don't see them in queue-5.15 , FYI. I don't think Greg got to these yet. We normally let these sit on the mailing list for a bit, for review. >Also I think along with 6 prerequisites and final 7th patch, we also >might need: commit: 9f33697ac7ff ("KVM: x86/mmu: Stop needlessly >making MMU pages available for TDP MMU faults") should be a clean >cherru-pick. Possibly, but there's no fixes or stable tag on it, so without an ack from the KVM folks it won't go in. -- Thanks, Sasha