Re: [PATCH 6.1.y 1/2] KVM: x86/mmu: Rename __direct_map() to direct_map()
Sean Christopherson <[email protected]>
| Newsgroups | org.kernel.vger.stable |
|---|---|
| Message-ID | <[email protected]> |
On Thu, Jul 30, 2026, Sasha Levin wrote: > From: David Matlack <[email protected]> > > [ Upstream commit 6c882ef4fc7bd99b67ad152e75428b669281c521 ] > > Rename __direct_map() to direct_map() since the leading underscores are > unnecessary. This also makes the page fault handler names more > consistent: kvm_tdp_mmu_page_fault() calls kvm_tdp_mmu_map() and > direct_page_fault() calls direct_map(). > > Opportunistically make some trivial cleanups to comments that had to be > modified anyway since they mentioned __direct_map(). Specifically, use > "()" when referring to functions, and include kvm_tdp_mmu_map() among > the various callers of disallowed_hugepage_adjust(). > > No functional change intended. > > Signed-off-by: David Matlack <[email protected]> > Reviewed-by: Isaku Yamahata <[email protected]> > Signed-off-by: Paolo Bonzini <[email protected]> > Message-Id: <[email protected]> > Signed-off-by: Paolo Bonzini <[email protected]> > Stable-dep-of: 2abd5287f083 ("KVM: x86: Check for invalid/obsolete root *after* making MMU pages available") > Signed-off-by: Sasha Levin <[email protected]> > --- Acked-by: Sean Christopherson <[email protected]>