Re: [PATCH v2 01/10] ceph: add ceph_folio_snap_context()

Matthew Wilcox <[email protected]> Wed, 5 Aug 2026 00:42:26 +0100
Newsgroups org.kvack.linux-mm,org.kernel.vger.ceph-devel,org.kernel.vger.linux-fsdevel,org.kernel.vger.linux-kernel
Message-ID <[email protected]>
On Tue, Aug 04, 2026 at 02:52:09PM -0400, Tal Zussman wrote:
> Add a folio-based counterpart to page_snap_context() that reads the
> snap context from folio->private directly.
> 
> Convert the three writeback paths that passed &folio->page to
> page_snap_context() to ceph_folio_snap_context(), removing three
> open-coded folio-to-page conversions. No functional change.
> 
> Signed-off-by: Tal Zussman <[email protected]>

Reviewed-by: Matthew Wilcox (Oracle) <[email protected]>